반응형

문제

N×N크기의 행렬로 표현되는 종이가 있다. 종이의 각 칸에는 -1, 0, 1의 세 값 중 하나가 저장되어 있다. 우리는 이 행렬을 적절한 크기로 자르려고 하는데, 이때 다음의 규칙에 따라 자르려고 한다.

  1. 만약 종이가 모두 같은 수로 되어 있다면 이 종이를 그대로 사용한다.
  2. (1)이 아닌 경우에는 종이를 같은 크기의 9개의 종이로 자르고, 각각의 잘린 종이에 대해서 (1)의 과정을 반복한다.

이와 같이 종이를 잘랐을 때, -1로만 채워진 종이의 개수, 0으로만 채워진 종이의 개수, 1로만 채워진 종이의 개수를 구해내는 프로그램을 작성하시오.

입력

첫째 줄에 N(1≤N≤3^7, N은 3^k 꼴)이 주어진다. 다음 N개의 줄에는 N개의 정수로 행렬이 주어진다.

출력

첫째 줄에 -1로만 채워진 종이의 개수를, 둘째 줄에 0으로만 채워진 종이의 개수를, 셋째 줄에 1로만 채워진 종이의 개수를 출력한다.

예제 입력 1

9
0 0 0 1 1 1 -1 -1 -1
0 0 0 1 1 1 -1 -1 -1
0 0 0 1 1 1 -1 -1 -1
1 1 1 0 0 0 0 0 0
1 1 1 0 0 0 0 0 0
1 1 1 0 0 0 0 0 0
0 1 -1 0 1 -1 0 1 -1
0 -1 1 0 1 -1 0 1 -1
0 1 -1 1 0 -1 0 1 -1

예제 출력 1

10
12
11

나의풀이

색종이 만들기 문제에서와 기본 로직은 비슷하다. 단지 4분할을 9분할로 바꾸고 -1,0,1의 경우들을 세어주면 된다. 아래 그림과 같이 분할을 하면된다.

IMG_9DB3878102E8-1


코드

# 1780번 종이의 개수

# 잘린 부분이 모두 한 숫자인지 확인
def isOne(n,startX,startY):
    is_same = True
    color = paper[startX][startY]

    for i in range(startX,startX+n):
        for j in range(startY,startY+n):
            if color != paper[i][j]:
                is_same = False
                break
        if not is_same:
            break

    if is_same:
        incre_cnt(color)
    else:
        # 9분할 과정
        isOne(n//3, startX, startY)
        isOne(n//3, startX, startY + n//3)
        isOne(n//3, startX, startY + (n//3)*2)
        isOne(n//3, startX + n//3, startY)
        isOne(n//3, startX + n//3, startY + n//3)
        isOne(n//3, startX + n//3, startY + (n//3)*2)
        isOne(n//3, startX + (n//3)*2, startY)
        isOne(n//3, startX + (n//3)*2, startY + n//3)
        isOne(n//3, startX + (n//3)*2, startY + (n//3)*2)

def incre_cnt(color):
    global cnt_minus, cnt_zero, cnt_one
    if color == -1:
        cnt_minus += 1
    elif color == 0:
        cnt_zero += 1
    else:
        cnt_one += 1

n = int(input())
paper = [list(map(int,input().split())) for _ in range(n)]

cnt_minus = 0
cnt_zero = 0
cnt_one = 0

isOne(n,0,0)

print(cnt_minus)
print(cnt_zero)
print(cnt_one)
반응형

BELATED ARTICLES

more