반응형
문제
정수를 저장하는 덱(Deque)를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 여덟 가지이다.
- push_front X: 정수 X를 덱의 앞에 넣는다.
- push_back X: 정수 X를 덱의 뒤에 넣는다.
- pop_front: 덱의 가장 앞에 있는 수를 빼고, 그 수를 출력한다. 만약, 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- pop_back: 덱의 가장 뒤에 있는 수를 빼고, 그 수를 출력한다. 만약, 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- size: 덱에 들어있는 정수의 개수를 출력한다.
- empty: 덱이 비어있으면 1을, 아니면 0을 출력한다.
- front: 덱의 가장 앞에 있는 정수를 출력한다. 만약 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- back: 덱의 가장 뒤에 있는 정수를 출력한다. 만약 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
입력
첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘쨰 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.
출력
출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.
예제 입력 1
15
push_back 1
push_front 2
front
back
size
empty
pop_front
pop_back
pop_front
size
empty
pop_back
push_front 3
empty
front
예제 출력 1
2
1
2
0
2
1
-1
0
1
-1
0
3
나의 풀이
queue는 뒤에 넣고 앞에서 빼는 구조이지만, deque는 앞과 뒤 모두 넣거나 빼기를 할 수 있는 구조이다. 따라서 큐 문제에 앞에 넣는 메서드와 뒤에서 빼는 메서드만 추가로 구현해주면 쉽게 풀 수 있다.
코드
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.List;
import java.util.StringTokenizer;
/**
* 10866번 덱
*/
public class Baekjoon10866 {
static List<Integer> deque = new ArrayList<>();
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
int n = Integer.parseInt(br.readLine());
for (int i=0; i<n; i++) {
StringTokenizer st = new StringTokenizer(br.readLine());
String op = st.nextToken();
if (op.equals("push_front")) {
push_front(Integer.parseInt(st.nextToken()));
} else if (op.equals("push_back")) {
push_back(Integer.parseInt(st.nextToken()));
} else if (op.equals("pop_front")) {
System.out.println(pop_front());
} else if (op.equals("pop_back")) {
System.out.println(pop_back());
} else if (op.equals("size")) {
System.out.println(size());
} else if (op.equals("empty")) {
if (empty()) System.out.println(1);
else System.out.println(0);
} else if (op.equals("front")) {
System.out.println(front());
} else if (op.equals("back")) {
System.out.println(back());
}
}
}
private static void push_front(int num) {
deque.add(0,num);
}
private static void push_back(int num) {
deque.add(num);
}
private static int pop_front() {
if (deque.isEmpty()) return -1;
else return deque.remove(0);
}
private static int pop_back() {
if (deque.isEmpty()) return -1;
else return deque.remove(deque.size()-1);
}
private static int size() {
return deque.size();
}
private static boolean empty() {
return deque.isEmpty();
}
private static int front() {
if (deque.isEmpty()) return -1;
else return deque.get(0);
}
private static int back() {
if (deque.isEmpty()) return -1;
else return deque.get(deque.size()-1);
}
}
반응형
'Programming > Algorithm' 카테고리의 다른 글
[백준5430번] AC / Python3 (0) | 2020.01.31 |
---|---|
[백준1021번] 회전하는 큐 / Python3 (0) | 2020.01.29 |
[백준1966번] 프린터 큐 (0) | 2020.01.29 |
[백준11866번] 요세푸스 문제 0 (0) | 2020.01.26 |
[백준2164번] 카드2 (0) | 2020.01.26 |